AWS Outage Impacting Third-party Providers

Incident Report for Elsmere Education

Resolved

All third parties have returned to normal operation after the AWS operations
Posted Oct 21, 2025 - 08:13 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 14:32 MDT

Investigating

Due to ongoing outages relates to AWS system outages some third-party services are still recovering.
Posted Oct 20, 2025 - 09:30 MDT
This incident affected: Omni Channel Communication Services (Forms, Email, Chat, Phone, SMS/MMS, etc.) (Ring Central Services), Call Center Services (Call Center Lead Management Services, Call Center Dialer Services), EPaaS Support Help Center (Service Portal Site, Jira Service Management Jira Service Management Web, Jira Service Management Jira Service Management Email Requests, Jira Service Management Authentication and User Management), and Integrated Event Services (Virtual & In-Person) (Calendly Services, Eventbrite Services).