Power BI - Performance Degradation

Incident Report for Elsmere Education

Resolved

All items are back to normal performance.
Posted Oct 21, 2025 - 17:35 MDT

Monitoring

Microsoft has applied a patch and we are monitoring services.
Posted Oct 21, 2025 - 12:00 MDT

Identified

Our third-party provider has identified a performance issue - https://support.fabric.microsoft.com/support/
Posted Oct 21, 2025 - 11:23 MDT
This incident affected: Elsmere Insights Services (Microsoft Power BI).